Cara membuat simple queue secara otomatis di mikrotik dengan tehnik mengambil IP address dari daftar di “address-list”.
Script dibawah ini adalah rule firewall yang menangkap IP address user yang trafik keluar melalui interface WAN/internet. Jadi user yang terhubung dengan internet (karena melewati interface wan) IP address user tersebut akan masuk daftar “address-list” -> user-internet.
| /ip firewall filter add action=add-src-to-address-list address-list="user-internet" chain=\ forward comment="tangkep user internet" out-interface=\ ether1-gateway |
Membuat Simple Queue Otomatis
Script dibawah ini digunakan untuk membuat simple queue otomatis di mikrotik pada IP address yang ditemukan di “ip firewall address-list (user-internet)” dan kecepatan dibatasi upload 128Kbps dan download 512Kbps
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 | /system script add name="automatic-queue [tekhnisi-it.blogspot.com]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":local hostip\r\ \n:local list\r\ \n:local testvalue\r\ \n \r\ \n:log info \"**starting - automatic queue create **\"\r\ \n \r\ \n :foreach i in=[/ip firewall address-list find] do={\r\ \n\r\ \n :set list ([/ip firewall address-list get \$i list] )\r\ \n :set hostip ([/ip firewall address-list get \$i address] )\r\ \n\r\ \n :set testvalue [/queue simple find name=\$hostip]\r\ \n\r\ \n :if ([:len \$testvalue] <= 0) do={\r\ \n :if (\$list = \"user-internet\") do={\r\ \n /queue simple add name=\$hostip comment=\"Automatic Simple Queues [tekhnisi-it.blogspot.com]\" target=\$hostip max-limit=1M/512K\r\ \n } else={\r\ \n }\r\ \n } else={\r\ \n \r\ \n }\r\ \n }\r\ \n \r\ \n:log info \"** ending - automatic queue create **\"" |
Kemudian dibuat scheduler agar script diatas berjalan otomatis setiap 10 menit
| /system scheduler add interval=10m name="automatic-queue [tekhnisi-it.blogspot.com]" on-event=\ "automatic-queue [tekhnisi-it.blogspot.com]" policy=\ ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=\ nov/23/2014 start-time=15:05:59 |
Atau kalau ingin membuat hanya untuk address lokal saja saya contohin ambil dari mangle..
| /ip fir mangle add action=add-src-to-address-list address-list=lokal address-list-timeout=1m \ chain=prerouting comment="LOKAL LIST" dst-address-type=!local \ in-interface=LOKAL src-address=192.168.77.0/24 |
Kemudian copas aja scriptnya di sys script
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 |
:local hostip :local list :local testvalue :log info "**starting - automatic queue create **"
:foreach i in=[/ip firewall address-list find] do={
:set list ([/ip firewall address-list get $i list] ) :set hostip ([/ip firewall address-list get $i address] )
:set testvalue [/queue simple find name=$hostip]
:if ([:len $testvalue] <= 0) do={ :if ($list = "lokal") do={ /queue simple add name=$hostip comment="Lokal[tekhnisi-it.blogspot.com]" target=$hostip max-limit=1M/2M } else={ } } else={ } } :log info "** ending - automatic queue create **" |
Kemudian dibuat scheduler agar script diatas berjalan otomatis setiap 10 menit sama kayak diatas
hasilnya
0 komentar:
Post a Comment
ilmu lebih berharga dari pada uang